Excel’de Ağırlıklı Ortalama Hesaplama

Ağırlıklı ortalamayı sayıların ağırlıklarının farklı olduğu zamanlarda kullanma ihtiyacı duyarız.

Normal ortalamayı sayıların değerlerinin toplanıp sayı adetine bölerek bulabiliyoruz. örneğin (9+10+5+10+6) / 5  hesabını yaparak 5 sayının ortalamasını 8 olarak buluruz. Excelde =ORTALAMA fonksiyonu ile bu işlemi kolaylıkla yapabiliriz.

Eğer bu 5 sayının ağırlıkları birbirinden farklı olsaydı, örneğin öğrencilerin final ve vize sınav sonuçları gibi, bu durumda ağırlı ortalama hesabını yapmamız gerekir. Aşağıdaki örneği inceleyelim.

Sınav Ağırlık Not
Vize-1 20 50
Vize-2 20 60
Ödev-1 5 90
Ödev-2 5 90
Final 50 65

 

Öğrencilerin sınav sonuçları ve bu sınavların ağırlıklarının içeren tablo yukarıdaki gibidir. Öğrencinin bu dersden aldığı genel başarı notu ağırlıklı ortalamaya göre hesaplanır.

Eğer sınavların ağırlıkları birbirinden farklı olmasaydı, bu dersden genel başarı notu aşağıdaki ekran görüntüsünde gözüktüğü gibi 71 olacaktı.

Fakat sınavların ağırlıkları göründüğü gibi farklı, dolayısıyla ağırlıklı ortalama hesaplaması yapmamız gerekiyor. Excelde bunu yapabilmek için ilk önce,

Ağırlıklar ile notları çarpıyoruz. =TOPLA.ÇARPIM(B2:B6;C2:C6)

Daha sonra  ağırlıkların toplamına  bölüyoruz. =TOPLA.ÇARPIM(B2:B6;C2:C6)/TOPLA(B2:B6)

Ağırlı ortalama hesabı yaparak ders için başarı notunu 63,5 bulduk.

Yukarıda kullanılan formüllerin ingilizce versiyonları için

SUMPRODUCT ve AVERAGE kullanabiliriz.

Benzer Sayfalar

Gelen Arama Kayıtları:

  • ağırlıklı ortalama hesaplama
  • ağırlıklı ortalama nasıl hesaplanır
  • AĞIRLIKLI ORTALAMA
  • excelde ortalama hesaplama
  • ağırlık ortalama hesaplama
  • excel ortalama hesaplama
  • excel ağırlıklı ortalama
  • excelde ağırlıklı ortalama hesaplama
  • excelde ağirlikli ortalama
  • excelde not ortalaması hesaplama formülü

View 3 comments on “Excel’de Ağırlıklı Ortalama Hesaplama

  1. acaba not ortalaması olarak tüm notları ele alıp sonra toplam ders saatine bölerek yapılan işlemi gösterir misiniz? lütfen

  2. 3000 satır veri var. verilerde ay yıl malzeme ayrımını pivot tablo üzerinde gösteriyoruz.

    burada pivot içinde ağırlıklı ortalama nasıl uygulanır. hesaplanmış alanda bunu gömebilirmiyiz.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir