Excel’de hata almadan toplama işlemi yapmak

Eğer toplama işlemi yapmak istediğimiz alanda en az bir hücrede hata varsa toplama işlemi sonucu da hatalı olarak gösterilecektir.

A1:A7 aralığı toplanmak isteniyor fakat A5 ve A7 hücrelerindeki hatalar yüzünden toplam sonucuda A8 hücresine hatalı gözükmekte.

Fakat; dizi formülleri kullanarak hata almadan bu aralık toplanabilir.

A1:A7 aralığında hatalı veriler olması rağmen aralığın toplama sonucu A8 hücresine dizi formülleri ile yazdırıldı.

Kullanılan formül :

=SUM(IF(ISERROR(A1:A7);0;A1:A7))

=TOPLA(EĞER(EHATALIYSA(A1:A7);0;A1:A7))

Fakat ekran görüntüsünde de göründüğü gibi formül { } arasına alınmış durumda. Bu bize bu satırın bir dizi formülü olduğunu gösteriyor.

Excel’e bunun bir dizi formülü olduğunu belirtmek için formül yazıldıktan sonra;

CTRL + SHIFT + ENTER ile formülün girişini yapıyoruz.

Bu formülde sırasıyla aşağıdaki işlemler yapılıyor.

  1. A1 den başlayıp A7’ye kadar her hücrenin hatalı olup olmadığı kontrol ediliyor
  2. Hatalıysa 0, hatalı değilse hücrenin değeri  ile dizi {32; 3; 52; 5; 0; 534; 0} oluşturuluyor
  3. Bu dizi toplanıyor.

 

 

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir